The Acoustic Guitar Forum

Go Back   The Acoustic Guitar Forum > General Acoustic Guitar and Amplification Discussion > Acoustic Amplification

Reply
 
Thread Tools
  #1  
Old 05-24-2020, 04:42 PM
Captain9 Captain9 is offline
Registered User
 
Join Date: Jun 2017
Posts: 8
Default DiMarzio Black Angel (Magnetic) volume issue...

Hi, maybe somebody can help clear this up for me. Getting almost no volume from the Black Angel.....here's what Im using.

Guitar with Black Angel into Allen and Health Zed 10fx > Main is at Unity >channel is the same > gain on channel at 40. Running into 2 QSC K10's volume both set to 0db with no issues. I tired different cables and channels on the mixer as well to make sure it wasn't something stupid.

I also have a K&K pure mini and Big Shot (for kick) wired to a second jack, they are both loud and clear at these settings.

Thanks for any insight!
Reply With Quote
  #2  
Old 05-31-2020, 04:57 AM
meb meb is offline
Charter Member
 
Join Date: Sep 2016
Location: Arkansas
Posts: 258
Default

To get enough volume, I almost always run the BA thru a preamp/Di via
XLR to the mixer. A preamp with a gain and volume control should work
also.....Baggs Venue or Fishman Platinum Pro and run thru via 1/4".

I am not sure this is your issue, but I thought I would throw it out there.
Good luck.
Reply With Quote
Reply

  The Acoustic Guitar Forum > General Acoustic Guitar and Amplification Discussion > Acoustic Amplification

Tags
dimarzio angel

Thread Tools



All times are GMT -6. The time now is 09:48 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Copyright ©2000 - 2020, The Acoustic Guitar Forum
vB Ad Management by =RedTyger=