The Acoustic Guitar Forum

Go Back   The Acoustic Guitar Forum > General Acoustic Guitar and Amplification Discussion > Acoustic Amplification

Reply
 
Thread Tools
  #16  
Old 01-18-2022, 01:10 AM
david57strat david57strat is offline
Registered User
 
Join Date: Feb 2011
Posts: 72
Default

Quote:
Originally Posted by jseth View Post
Surprised that no one has said this yet...

The FIRST thing to do is to put a fresh battery in it! Always start with the easiest "fix" before progressing to the more involved...

And, just so you know - De-Oxit is terrific stuff but it will harm the finish... do whatever you have to do to avoid getting it on the guitar's surface. For tight places, I'll spray a bit into a tiny cup/bowl I've fabricated from foil or some such - even the cap to the De-Oxit works - then quickly (it will evaporate!) use a Q-tip or something like that to apply.
^^^^ Sage advice.

When working with jacks, I usually spray a plug (all by itself..not attached to a cable), then work the plug in and out of the jack, and give it a number of twists, while plugged in, to work the oxidation free. I do this maybe once a year or so, on all plugs and jacks, to keep them clean and protected.

If more is needed directly into the problem area, I may wrap a small rag around the area that can be messed up, holding the towel in place with one hand and and carefully spraying within that area, with the other hand, so there won't be any splatter affecting any other surrounding area. I still try to use short bursts.

While this stuff does evaporate fairly quickly, I still try to wait a minute or so, before powering up anything again, just to be sure - especially if I've sprayed directly into a plug.

Last edited by david57strat; 01-18-2022 at 01:16 AM.
Reply With Quote
  #17  
Old 01-18-2022, 09:08 AM
Joe.Manganese Joe.Manganese is offline
Registered User
 
Join Date: Oct 2020
Posts: 56
Default

Speaking about the actual problem, cracks pops etc., it is a Matrix Vt Enhance on a Martin. I have a Martin with the same pickup, and when the battery is exhausted that is what happens.
It is a digital artifact problem due to the battery less than 8 volts.
Reply With Quote
  #18  
Old 01-23-2022, 03:25 PM
lowrider lowrider is offline
Registered User
 
Join Date: Dec 2016
Posts: 5,263
Default

Thanks everyone. It's all taken care of and it's playing beautifully.

Getting the cleaner was easy. Getting the battery was an ordeal though. First I ordered them to go to my Long Island house because I was going to be there all last week, but then it was going to take longer so I canceled. I was on L I so I could have just gone to the store but Omicron is blooming down there so I ordered again from Amazon. The cleaner arrived, right on time on Thursday. The batteries took the long route and got here today.

I cleaned the contacts on both guitars with pickups and put a new battery in the one with the Matrix and everything is great. I played both this afternoon and loved them both.

Thanks again, all is good!
Reply With Quote
  #19  
Old 01-24-2022, 09:10 PM
david57strat david57strat is offline
Registered User
 
Join Date: Feb 2011
Posts: 72
Default

Quote:
Originally Posted by lowrider View Post
Thanks everyone. It's all taken care of and it's playing beautifully.

Getting the cleaner was easy. Getting the battery was an ordeal though. First I ordered them to go to my Long Island house because I was going to be there all last week, but then it was going to take longer so I canceled. I was on L I so I could have just gone to the store but Omicron is blooming down there so I ordered again from Amazon. The cleaner arrived, right on time on Thursday. The batteries took the long route and got here today.

I cleaned the contacts on both guitars with pickups and put a new battery in the one with the Matrix and everything is great. I played both this afternoon and loved them both.

Thanks again, all is good!
Thanks for the update! That is excellent news!

Enjoy, brother!
Reply With Quote
  #20  
Old 01-26-2022, 07:08 PM
slooky slooky is offline
Registered User
 
Join Date: Jun 2008
Location: Niagara Ontario Canada
Posts: 429
Default

excellent!
Reply With Quote
Reply

  The Acoustic Guitar Forum > General Acoustic Guitar and Amplification Discussion > Acoustic Amplification

Thread Tools





All times are GMT -6. The time now is 07:12 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
Copyright ©2000 - 2022, The Acoustic Guitar Forum
vB Ad Management by =RedTyger=