The Acoustic Guitar Forum

Go Back   The Acoustic Guitar Forum > General Acoustic Guitar and Amplification Discussion > Acoustic Amplification

Reply
 
Thread Tools
  #1  
Old 03-03-2021, 08:57 PM
wweiss wweiss is offline
Registered User
 
Join Date: Feb 2018
Posts: 106
Default Fishman SA 220

I have a Fishman SA 220 bought in 2015
Recently I hear a static sound when I'm close to the speaker. Gain and volume are less than 12:00. I heard this unit had a problem with dirty pots. Could this be the problem?
Reply With Quote
  #2  
Old 03-03-2021, 09:54 PM
Slim Slim is offline
Registered User
 
Join Date: Aug 2011
Location: West Michigan
Posts: 376
Default

Yep! Easy fix if you have an allen wrench and can of compressed air. Like seemingly most folks that have owned one long, Iíve cleaned mine a few times over the last decade with good results. I think the maintenance is worth it. I have a sealed pot 330X that stays clean but does not sound as open as the SA220.
Reply With Quote
  #3  
Old 03-03-2021, 11:31 PM
gfirob gfirob is offline
Registered User
 
Join Date: Mar 2017
Location: Central Vermont
Posts: 820
Default

If you contact Fishman they will email you very detailed instructions about cleaning the pots, with photographs.
__________________
2003 Martin OM-42, K&K's
1932 National Style O, K&K's
1936 Kalamazoo KG-14, K&K's
1957 National 1155 (Gibson J45 body, National neck) K&K's
1967 Gretsch 6120 Chet Atkins Nashville
2005 Warmoth Telecaster, Lindy Fralins
Ear Trumpet Labs Edwina
Tonedexter
Reply With Quote
  #4  
Old 03-04-2021, 05:07 AM
_Mike_ _Mike_ is offline
Registered User
 
Join Date: Jul 2007
Location: SouthCoast, MA
Posts: 48
Default

I have the Fishman instructions. Got them from a member here. Happy to pass them along. Just pm me an email address.

BTW - the fix worked great! Cured a completely dead channel, and not that hard to do.
Reply With Quote
  #5  
Old 03-04-2021, 08:43 PM
wweiss wweiss is offline
Registered User
 
Join Date: Feb 2018
Posts: 106
Default

Thanks Mike! Please e-mail me the instructions:
[email protected]
Reply With Quote
  #6  
Old 03-05-2021, 05:39 AM
_Mike_ _Mike_ is offline
Registered User
 
Join Date: Jul 2007
Location: SouthCoast, MA
Posts: 48
Default

Message sent.

Good luck!
Reply With Quote
  #7  
Old 03-07-2021, 05:18 PM
eyesore eyesore is offline
Charter Member
 
Join Date: Feb 2007
Posts: 1,286
Default

Hi guys ; I also own the soloamp and could use those instrutions [ warm months for gigs are coming up; I hope] Thanks!!
Reply With Quote
  #8  
Old 03-08-2021, 05:28 AM
_Mike_ _Mike_ is offline
Registered User
 
Join Date: Jul 2007
Location: SouthCoast, MA
Posts: 48
Default

Quote:
Originally Posted by eyesore View Post
Hi guys ; I also own the soloamp and could use those instrutions [ warm months for gigs are coming up; I hope] Thanks!!
They are posted online somewhere (found them once in a google search) but send me an email and Iíll forward them
Reply With Quote
  #9  
Old 03-08-2021, 10:44 AM
wweiss wweiss is offline
Registered User
 
Join Date: Feb 2018
Posts: 106
Default

I did it! Problem gone. Sounds like new. I was so frustrated I was about to order a new SA330X . It sounded like the ocean in the background which I could hear over quiet playing.
Guitar Center offered me $300 for my perfect condition SA220 which I paid $1,000 back in 2015. Frustrating thing is I "never" gigged outside with this unit and always kept it covered when not in use. I think the problem was I use it only every few months. Still wondering how this happened? Any suggestions so this doesn't happen again?

Thanks again Mike :]

Last edited by wweiss; 03-08-2021 at 11:20 PM.
Reply With Quote
  #10  
Old 03-08-2021, 03:07 PM
_Mike_ _Mike_ is offline
Registered User
 
Join Date: Jul 2007
Location: SouthCoast, MA
Posts: 48
Default

Youíre welcome. Glad you got it fixed. The instructions were passed on to me from someone here, so happy to pass them on.

My understanding is that the pots on the 220 are open (which is why the canned air works) and sealed on the 330.

The prescription to prevent this happening is to use it more Seriously. I bought mine for less than what GC wanted to give you, because one channel was ďdeadĒ. I use mine once a week, but rotate the dials each time I use it.
Reply With Quote
  #11  
Old 03-08-2021, 06:06 PM
gfirob gfirob is offline
Registered User
 
Join Date: Mar 2017
Location: Central Vermont
Posts: 820
Default

I think these are great units, and the problem described (which I also experienced and fixed) is minor when compared to the overall performance of the amplifier. You get a little more power and options on the 330, but if you have a functioning 220 I think its hard to justify the bump up to the new unit, at least for me.
__________________
2003 Martin OM-42, K&K's
1932 National Style O, K&K's
1936 Kalamazoo KG-14, K&K's
1957 National 1155 (Gibson J45 body, National neck) K&K's
1967 Gretsch 6120 Chet Atkins Nashville
2005 Warmoth Telecaster, Lindy Fralins
Ear Trumpet Labs Edwina
Tonedexter
Reply With Quote
Reply

  The Acoustic Guitar Forum > General Acoustic Guitar and Amplification Discussion > Acoustic Amplification

Thread Tools





All times are GMT -6. The time now is 12:25 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
Copyright ©2000 - 2021, The Acoustic Guitar Forum
vB Ad Management by =RedTyger=