The Acoustic Guitar Forum

The Acoustic Guitar Forum (https://www.acousticguitarforum.com/forums/index.php)
-   Open Mic (https://www.acousticguitarforum.com/forums/forumdisplay.php?f=12)
-   -   Adding images to your posts (https://www.acousticguitarforum.com/forums/showthread.php?t=231872)

J.R. Rogers 10-29-2011 01:11 PM

Adding images to your posts
 
Adding pictures to your post is easy. All the photos that you see on the AGF are hosted somewhere else - you don't actually upload photos to the AGF. There are a number of websites that do a better job of allowing you to manage your photos, albums, etc., and they are designed to work with forums like ours. The most popular are:
http://picasaweb.google.com/
http://imgur.com/
http://photobucket.com/
http://www.flickr.com/
http://imageshack.us/

Once you upload your photos, they give you a link to your pictures which you can use on the forum or on your website, etc. The link looks something like this:

PHP Code:

[img]http://i958.photobucket.com/albums/ae69/edwinsonguitar/Edwinson%20Guitars%20for%20Healdsburg/IMG_0018-1.jpg[/img] 

you can insert images into your post using the Insert Image button or just cutting and pasting the link from photobucket/flickr into your message. The magic is in the [img] and [/img] tags that you put around the link to the image. This tag causes your image to be displayed on the forum if used correctly. Using the above example link, you get this:

http://i958.photobucket.com/albums/a...IMG_0018-1.jpg

Video walk-through:

https://www.youtube.com/watch?v=kHBePp56Pxo


mc1 04-11-2012 03:55 PM

Quote:

Originally Posted by Chicago Sandy (Post 2974284)
It STILL doesn't work for me--whether I use the "insert image" button or place those HTML tags around the URL (which Flickr says IS the exact url to copy and paste to share the photo), all I get is that stupid little ? inside a blue box. Like so:http://www.flickr.com/photos/sandyandina/6989038617/

http://farm8.staticflickr.com/7064/6...3e6629_m_d.jpg

it seems to me that flickr isn't generating the proper link. it looks like a link to the page, but not the photo. i used the download link.

i did notice this message on the flickr page:

Where is the HTML code and photo file link?


The HTML code to embed a photo in a web page that you used to find on the All Sizes page is now only in the Share menu above the photo, to the right of the Actions menu. We now also include BBCode! (standard message board code)

There are a few cases where the code may not be available: 1) If the photo is restricted. 2) If that person has turned off "Share this" or access to original files.

The direct link to a photo file is no longer shown on the page. Per the Flickr Community Guidelines "pages on other websites that display content hosted on flickr.com must provide a link from each photo or video back to its page on Flickr." Linking directly to the photo file doesn't do this.

PaganBeef 05-28-2013 01:52 AM

How to get an image to post

First, get youself up on photobucket. Do that. Once there you can upload any picture from your computer.
Then, click on the picture you want so it appears alone.
Sometimes you need to go to your library to do this properly, and then click your picture.
Over on the right you will see the image links:

Email & IM
Direct link
HTML code
IMG code

Click into the Direct link box - and the word 'Copied' appears.
Create a new post, or open the AGF thread you need and click 'Post Reply'.
Type any additional message text that you want to appear above the photo in your post, maybe, "Here's my beautiful new guitar, finally." and hit enter TWICE. This will leave a space between your text and your picture.
Now, select the 'mountains' icon that says 'Insert Image'.
Now, click into that window that pops up and hold 'Ctrl' and 'v' to paste your link. Overwrite the http://
Then click 'Preview Post' before you 'Submit Reply'.

http://i851.photobucket.com/albums/a...ps01e14771.jpg

robj144 07-04-2013 01:05 PM

Here is a video that walks through how to add a photo:

http://www.screencast.com/t/Cl4MLqPPxrBs


Right clicking in Internet Explorer is not quite as elegant, see post below.

BGS 07-06-2014 05:38 PM

I don't suppose we could add the ability to resize images to the [img] tag, could we? Like this:

Code:

[img size=400x300]http://blahblah[/img]
The forum would then resize that photo to 400px x 300px. This exists, but this forum doesn't support it as of now.

Inyo 09-02-2015 11:57 AM

Quote:

Originally Posted by KarlM (Post 4533897)

You're using dropbox. So, try this fix-it. To embed images housed at dropbox, you need to add ?dl=1 at the very end of your public URL:

Your originally posted public URL: https://www.dropbox.com/sc/4tye75j3g...1WGf4I3xMgnzva

That URL, with ?dl=1 at the end:

https://www.dropbox.com/sc/4tye75j3g...I3xMgnzva?dl=1

Put that URL between the IMG tags:

https://www.dropbox.com/sc/4tye75j3g...I3xMgnzva?dl=1

Mr Fixit eh 11-20-2015 03:46 PM

Test
 
[IMG]https://www.dropbox.com/s/69xdzmddrz0lh1j/IMG_0937.JPG?dl=0[/IMG]

Inyo 11-22-2015 03:41 PM

Quote:

Originally Posted by Mr Fixit eh (Post 4721884)
Trying to test posting a photo via dropbox. I have the image in the 'public' folder and permissions are set 'anyone with link can see', but the image is not coming through. Like this...

https://www.dropbox.com/s/69xdzmddrz..._0937.JPG?dl=0

https://photos-2.dropbox.com/t/2/AAC...&size=1024x768

To get a dropbox image to embed properly, you need change the "0" to a "1" at the very end of your public URL (your first image, above).

Here's the original public URL you provided: https://www.dropbox.com/s/69xdzmddrz..._0937.JPG?dl=0

And here's the URL you need to place between the IMG tags: https://www.dropbox.com/s/69xdzmddrz..._0937.JPG?dl=1

So, here's the final result:

https://www.dropbox.com/s/69xdzmddrz..._0937.JPG?dl=1

Edit: Original image from "Mr Fixit eh" is no longer housed with dropbox. That's why the image does not show in this post.

Mr Fixit eh 11-25-2015 04:00 PM

Boy, I must be a whole lot more stupid than I thought I was. Rather than resizing photos and using Dropbox, I'm trying to use PicasaWeb.

The photo album is set to 'anyone with link can see'. I'm clicking on the 'link to this photo' and then clicking 'insert image' on the AGF, but it is not working. https://picasaweb.google.com/lh/phot...eat=directlink

The link itself is working, you can view the test photo Photo Link Here

This is the link https://picasaweb.google.com/lh/phot...eat=directlink

What am I doing wrong? I'm starting to go bonkers - well more bonkers than usual:D

Steve

Mr Fixit eh 11-25-2015 06:35 PM

:rolleyes:Well, I've made a little progress. I realized that the above link does not have a .jpg extension - which is apparently required.

I went to Picasaweb and opened the photo, and clicked on the 'Link to this Photo', then went to the 'Embed Image' and selected the 'large' size. Then I copied the link to Notepad and you get this:

Quote:

<table style="width:auto;"><tr><td><a href="https://picasaweb.google.com/lh/photo/fsToHL-9dlhUH9TVnpxP8DEjQOYoXzBwkKyddtT39G8?feat=embedweb site"><img src="https://lh3.googleusercontent.com/-C_FxC2fGinc/VlYJYCBx_3I/AAAAAAAAANE/XcKn1ep4GNc/s640-Ic42/IMG_0936.JPG" height="480" width="640" /></a></td></tr><tr><td style="font-family:arial,sans-serif; font-size:11px; text-align:right">From <a href="https://picasaweb.google.com/103431728375121234842/Public02?authuser=0&feat=embedwebsite">Public</a></td></tr></table>
Look for the URL that ends in '.jpg', in this case:
Copy this carefully - without the quote marks. Open the 'Insert Image' tool in the AGF forum and paste this link into the dialogue box.

This is what you get:

https://lh3.googleusercontent.com/-C...2/IMG_0936.JPG


Surely there must be a more elegant method to embed photos from PicasaWeb??? Oh, wait - it is a Google product, isn't it:rolleyes:

Mr Fixit eh 11-27-2015 01:29 PM

Using PicassaWeb to insert photos
 
So, I've found out a little more about embedding a photo hosted on PicasaWeb:

How you 'grab' the link from PicasaWeb depends on the browser you are using. In order for the [img] [/img] tags to work correctly in the AGF, they must have an extension, usually .jpg/ .gif/ .png/ .pdf. On Picasweb, when you click on 'link to this photo' and then copy from the 'link' box, the link ends with "feat=directlink". This link will not work to display an image on AGF or other bulletin boards.

In Moxilla Firefox, you can right-click the photo itself and select "Copy Image Location" and then paste this between the [img][/img] tags in AGF (Using the e 'Insert Image' button in AGF. I haven't tried the other browsers.

When you right-click a photo when using PicasaWeb In IE you do not get an option like this. You can, however, right-click the photo and select 'Properties', then copy the URL from the properties dialogue box. This URL has the .jpg extension and works to display the photo in AGF.

Then with a little more research, I discovered in Picasaweb (in all browsers) when you click 'link to this photo', then select 'image only (no link) - then you can copy the 'Embed Photo' link and it will have the .jpg extension and it will work. Not exactly intuitive, but it works.

The underlying problem is that PicasaWeb does not include the .JPG file extension if you click on the 'link' box.

Steve

lfoo6952 03-09-2016 07:14 PM

testing to see if it works
[img]<table style="width:194px;"><tr><td align="center" style="height:194px;background:url(https://www.gstatic.com/pwa/s/v/ligh...background.gif) no-repeat left"><a href="https://picasaweb.google.com/116524433147019227160/Mar92016?authuser=0&authkey=Gv1sRgCO3A0qzxp-rUCg&feat=embedwebsite"><img src="https://lh3.googleusercontent.com/-8QtBgibjpaI/VuDX20_V-7E/AAAAAAAAAMA/6Es_HGleze4/s160-c-Ic42/Mar92016.jpg" width="160" height="160" style="margin:1px 0 0 4px;"></a></td></tr><tr><td style="text-align:center;font-family:arial,sans-serif;font-size:11px"><a href="https://picasaweb.google.com/116524433147019227160/Mar92016?authuser=0&authkey=Gv1sRgCO3A0qzxp-rUCg&feat=embedwebsite" style="color:#4D4D4D;font-weight:bold;text-decoration:none;">Mar 9, 2016</a></td></tr></table>[/img]

Sorry! It didn't work

Jeremy 03-09-2016 08:02 PM

Quote:

Originally Posted by lfoo6952 (Post 4858859)
testing to see if it works
[img]<table style="width:194px;"><tr><td align="center" style="height:194px;background:url(https://www.gstatic.com/pwa/s/v/ligh...background.gif) no-repeat left"><a href="https://picasaweb.google.com/116524433147019227160/Mar92016?authuser=0&authkey=Gv1sRgCO3A0qzxp-rUCg&feat=embedwebsite"><img src="https://lh3.googleusercontent.com/-8...2/Mar92016.jpg" width="160" height="160" style="margin:1px 0 0 4px;"></a></td></tr><tr><td style="text-align:center;font-family:arial,sans-serif;font-size:11px"><a href="https://picasaweb.google.com/116524433147019227160/Mar92016?authuser=0&authkey=Gv1sRgCO3A0qzxp-rUCg&feat=embedwebsite" style="color:#4D4D4D;font-weight:bold;text-decoration:none;">Mar 9, 2016</a></td></tr></table>[/img]

Sorry! It didn't work

Embed codes like that don't work on forums. You need to find the direct URL ending in the file format of the image (e.g. .jpg) and paste that in between the IMG tags.

In the code above it looks like you're trying to embed: https://lh3.googleusercontent.com/-8...2/Mar92016.jpg

https://lh3.googleusercontent.com/-8...2/Mar92016.jpg

rokdog49 02-01-2017 11:41 AM

Use "Imgur" it's easy.

The Bard Rocks 03-16-2017 06:51 PM

photos
 
I have photos already on my websites. Can I use these? (somehow) I am cautious about joining 3rd party things and am sick and tired of user names and passwords that sometimes work and was hoping to short circuit a process that I dread.


All times are GMT -6. The time now is 12:56 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Copyright ©2000 - 2018, The Acoustic Guitar Forum

vB Ad Management by =RedTyger=